Volkswagen Jetta Junkies banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have this 99.5 2.0L thats both losing antifreeze and oil. the oil has the most disqusting sludge formation ive ever seen, yet the oil is relatively clean for the amount of sludge there is. the antifreeze does not leak ou, it looks like its being eaten by the engine. ive heard that this engine had some of the piston rings stamped upside-down, thus installed upside-down. The running light for the back also dosent work, is there a known common fix for this? can someone enlighten me with any info they have on this matter? it might be the head gasket, but its been eating oil for a while.
 

· Registered
Joined
·
323 Posts
I have this 99.5 2.0L thats both losing antifreeze and oil. the oil has the most disqusting sludge formation ive ever seen, yet the oil is relatively clean for the amount of sludge there is. the antifreeze does not leak ou, it looks like its being eaten by the engine. ive heard that this engine had some of the piston rings stamped upside-down, thus installed upside-down. The running light for the back also dosent work, is there a known common fix for this? can someone enlighten me with any info they have on this matter? it might be the head gasket, but its been eating oil for a while.
I would think the o-rings too. For something like that I think it would just be best to suck it up and go to the dealer. Good luck.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top