Volkswagen Jetta Junkies banner
1 - 8 of 8 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
so i noticed on my mk2 92 jetta that i only have high speed on my blower. it has 4 settings on it, but only works on the 4th one. so i figured it would be the resistor pack because from my previous experience, that's what it was every single time without failure. so i went on to german auto parts and ordered a resistor pack. when it came in the mail i went out to replace it and ripped out the pack that was on the bottom of the blower box aka heater core and the part that i'm seeing looks nothing like the part i ordered. there's only 2 wires going to that and every resistor pack that i saw had 4 wires with 4 prongs for 4 speeds. so is this the resistor pack or is that something else? and if that is something else, where's the resistor pack at? didn't know if there was already a thread on this or not. tried browsing for awhile and then gave up. help would be appreciated. thanks:D
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #2 ·
nevermind, i found where it was finally. i pulled out the glovebox for shits n giggles and found the resistor pack sitting on top of the blower motor. was right there and easy to get to once you take the glove box out. to take out the glove box, have to take out the screws on both left and right sides, then the 3 screw across the top inside the box, and then on the lid, you pull off the 3 round caps and there's 3 screws behind that. so blower speeds are all working again
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #3 ·
now i'm having an issue though after replacing that resistor pack. after i plugged that in, i know how have power to all my accessories without a key in the car. so i have contant power which don't make sense. i can have the radio on, turn on the blower, can run the wipers, can do anything. like it turned on a main power switch or something. its freaking weird. and not only that, when i change the blend doors to anything but the feet and upper vents, the outside cooling fan kicks on. like wtf?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
i got some really sweet photos for this so you people can see where this at, cept the site won't let me load them for whatever reason. says they're too big and i got them down pretty small. any smaller, you won't see anything
 

·
Digifook.
Joined
·
716 Posts
The blower motor comes out of the plenum by simply turning it and letting it fall. No need to remove the glove box.

Its always easier just to buy a used blower motor with the resistor.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
the blower i got actually had 4 bolts holding it in place. one up top behind the glove box and 3 across the bottom. replaced the resistor pack and got it working but after i tore the fan out, i found that i need to get a new one. its all worn at the shaft. just wobbles like crazy. so i'm going to order one from german auto parts. thanks though
 

·
Registered
Joined
·
37 Posts
Did you ever find out what was happening with your other control instruments and why they were coming on with no key in? And the german auto part then worked? I'm looking into doing the same thing with my car!

Thx!
 
1 - 8 of 8 Posts
Top