Volkswagen Jetta Junkies banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I recently saw that the engine block light came on my VW Jetta 2007 GLI. I went to an AutoZone and the code P2181 came up, referring to cooling system performance. The reasons were low coolant, failed radiator/water pump, and or ECT sensor.

The coolant was well above the minimum amount. I just got my water pump replaced (as part of the timing belt kit) back in early March. From researching online, I've seen quite a few instances where the problem was solved by replacing the thermostat. That is something I wouldn't mind doing myself, but I don't want to spend money to go to a auto shop and or dealer, where they charge 100 bucks just to diagnose it and that doesn't include the parts and labor. I saw a thermostat is around 30 to 50 bucks online.

Anybody else have this issue before? And if so, what did you do to resolve it?

Thanks for the help in advance! :)
 

·
Registered
Joined
·
17 Posts
An engine coolant temp. Sensor is what I have relaced in the past and much cheaper and easier to do than a thermostat it is the sensor for the computer.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
I know this is elementary, but I hear the fans moving. I just can't locate them. Are the fans located at the same place for all Jetta's? I have a 2007 Jetta GLI

Thank you
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Nevermind. I did find the fans. I guess I was looking for something else. The bigger fan is moving but the smaller isn't moving when I initiate the engine. Is the second one suppose to kick in right at the beginning when you start the car or does it kick in later when you're driving?
 

·
Asshat Patrol
Joined
·
1,796 Posts
They should both be moving.

Is it overheating?
 
1 - 7 of 7 Posts
Top