Volkswagen Jetta Junkies banner

1 - 3 of 3 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I'm new to this I haven't found what I was looking for does anyone know and DIY on soldering cold joints on mk3 jettas? I want something with pictures it's my first time doing this so I'm a little nervous on messing up?
Second question
Okay my 98 jetta 5spd cluster seems to be working fine except for the speedometer which only works intermediate if I tap on it sometimes the needs goes up or if Im driving and the speedometer is working i hit a bump the speedo drops down
and theres just time where it doesnt work at all even if i tap on it
now i did get the P0501 CEL code which i replaced the sensor
but still nothing so the question is "is it a cold joint, or should i replace the speedometer motor?
the reason I'm not sure is because if it was a cold solder joint wouldn't the whole cluster not work???
 

·
Registered
Joined
·
3 Posts
I had a similar issue with my speedo in my '97 Jetta. What I found was that this is a common occurrence with our cars. Apparently there is a miss connection inside the speedo to the chip that registers the odometer, fuel gauge etc... I found this guy in Canada that can fix the issue without having to replace the entire speedo. Great way to keep original parts... His name is Bob Dorsey, I can look for his info and send that out
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
I had a similar issue with my speedo in my '97 Jetta. What I found was that this is a common occurrence with our cars. Apparently there is a miss connection inside the speedo to the chip that registers the odometer, fuel gauge etc... I found this guy in Canada that can fix the issue without having to replace the entire speedo. Great way to keep original parts... His name is Bob Dorsey, I can look for his info and send that out
Do you know how he fixed it cuz I'm on a deadline to get it fix cuz I got to pass smog lol


Sent from AutoGuide.com Free App
 
1 - 3 of 3 Posts
Top